in PHP

Fix error install phalconphp 3

Since I use Apricity and its arch linux ‘blood’ make me use latest php version (php 7.0.9 in time of writing) then I can’t get latest phalconphp (version 2). Finally I see phalconphp 3 released. I got little problem to install it but at least i know the error is in my side.

/tmp/yaourt-tmp-alamsyahr/aur-php-phalcon/src/cphalcon-3.0.0/build/php5/64bits/phalcon.zep.c:203:30: fatal error: ext/spl/spl_heap.h: No such file or directory
#include <ext/spl/spl_heap.h>
^
compilation terminated.
make: *** [Makefile:164: phalcon.lo] Error 1
==> ERROR: A failure occurred in build().
Aborting…
==> ERROR: Makepkg was unable to build php-phalcon.
==> Restart building php-phalcon ? [y/N]
==> ————————————
==> y
==> Edit PKGBUILD ? [Y/n] (“A” to abort)
==> ————————————
==>

==> php-phalcon dependencies:
– php>=5.5 (already installed)
– gcc (already installed) [makedepend]

==> Continue building php-phalcon ? [Y/n]
==> ————————————-
==> n

php-config –version
5.2.17
?  ~
?  ~ php -v
PHP 7.0.9 (cli) (built: Jul 20 2016 17:12:28) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
?  ~ whereis php-config
php-config: /usr/bin/php-config /usr/local/bin/php-config /usr/share/man/man1/php-config.1.gz
?  ~ /usr/bin/php-config –version
7.0.9
?  ~ /usr/local/bin/php-config –version
5.2.17

Need to fix 5.2.17 version 🙂

ls -l /usr/local/bin | grep php-config
-rwxr-xr-x 1 root root     2104 Apr 18 15:39 php-config

sudo rm /usr/local/bin/php-config
rm: remove write-protected regular file ‘/usr/local/bin/php-config’? y

fixed.

php-config –version
7.0.9

Yes, the error came since the output of php-config –version is 5.2.17 just remove it and I can continue for the ride 🙂